SharePoint – Este produto requer o Microsoft .net Framework 4.5.

Introdução

Esse artigo tem como finalidade ajudar na instalação do SharePoint 2003 quando o mesmo não reconhece como instalado o .NET Framework 4.5 dando o erro abaixo:

Não é possível continuar devido os erros a seguir:
Este produto requer o Microsoft .net Framework 4.5.

Causa

Isso normalmente ocorre quando o servidor possui o .NET Framework 4.6 instalado e o instalador do SharePoint não reconhece o mesmo.

Resolução

Para resolver essa situação é necessário utilizar uma DLL do SharePoint na instalação do mesmo. Para isso siga os passos do KB abaixo, que resume em:

– Copiar os arquivos de instalação para o drive C;

– Copiar a DLL para o diretório de Setup que você copiou da mídia de instalação;

– Executar novamente a instalação a partir do local copiado e não mais da mídia de instalação para que o instalador leia a DLL e reconheça o .NET Framework 4.6

https://support.microsoft.com/pt-br/help/3087184/sharepoint-2013-or-project-server-2013-setup-error-if-the-.net-framework-4.6-is-installed